summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2022-02-22 18:57:16 (GMT)
committerBrad King <brad.king@kitware.com>2022-02-22 18:58:35 (GMT)
commit6f7580c7ad7de056088a617b212e221e45f5d528 (patch)
tree263d02d31e25023c401d1b4a7683ba65f2caa016 /Tests/CMakeLists.txt
parentc737367e92ef4f1b4cefcc0ead4d3f36ee1cd957 (diff)
downloadCMake-6f7580c7ad7de056088a617b212e221e45f5d528.zip
CMake-6f7580c7ad7de056088a617b212e221e45f5d528.tar.gz
CMake-6f7580c7ad7de056088a617b212e221e45f5d528.tar.bz2
Tests: Run CTest.UpdateP4 tests only if explicitly enabled
The test occasionally fails with "Gave up waiting for server to start". Drop our heuristic so we can enable it only on specific builds.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 8151bfe..65f72c5 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2674,16 +2674,10 @@ if(BUILD_TESTING)
endif()
# Test CTest Update with P4
- if(NOT DEFINED CMake_TEST_CTestUpdate_P4 OR CMake_TEST_CTestUpdate_P4)
+ if(CMake_TEST_CTestUpdate_P4)
find_program(P4_EXECUTABLE NAMES p4)
find_program(P4D_EXECUTABLE NAMES p4d)
mark_as_advanced(P4_EXECUTABLE P4D_EXECUTABLE)
- endif()
- if(NOT DEFINED CMake_TEST_CTestUpdate_P4 AND P4_EXECUTABLE AND P4D_EXECUTABLE
- AND (UNIX OR NOT "${P4_EXECUTABLE};${P4D_EXECUTABLE}" MATCHES "cygwin"))
- set(CMake_TEST_CTestUpdate_P4 1)
- endif()
- if(CMake_TEST_CTestUpdate_P4)
if(NOT P4_EXECUTABLE OR NOT P4D_EXECUTABLE)
message(FATAL_ERROR "CMake_TEST_CTestUpdate_HG enabled but P4_EXECUTABLE and P4D_EXECUTABLE are not both not found.")
endif()