summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorClinton Stimpson <clinton@elemtech.com>2012-02-29 14:55:31 (GMT)
committerClinton Stimpson <clinton@elemtech.com>2012-02-29 14:55:31 (GMT)
commitab9661c1dd4340af5a84244c920d94bddd1c8e90 (patch)
treeee7dce2f71577effa1e84efe0bab6dbb3d723897 /Tests/CMakeLists.txt
parent52e827964843cdf25ec3be1af98cb47c17800545 (diff)
downloadCMake-ab9661c1dd4340af5a84244c920d94bddd1c8e90.zip
CMake-ab9661c1dd4340af5a84244c920d94bddd1c8e90.tar.gz
CMake-ab9661c1dd4340af5a84244c920d94bddd1c8e90.tar.bz2
Remove QtGui dependency in Qt4Deploy test and verify QtSql existance.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index cc2ae5e..13e57d9 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -268,7 +268,7 @@ IF(BUILD_TESTING)
# run test for DeployQt4 on supported platforms/compilers (which depends on BundleUtilities)
# this test also depends on the existence of the standard qtiff plugin
- if(QT4_WORKS)
+ if(QT4_WORKS AND QT_QTSQL_FOUND)
ADD_TEST(Qt4Deploy ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/Qt4Deploy"