summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-12-02 19:34:41 (GMT)
committerBrad King <brad.king@kitware.com>2016-12-02 20:11:49 (GMT)
commit027ce359ff7454ac0aca4d9a9208759ef4b9c8b7 (patch)
treeafdd06ef04418b23e20c39e522552bf778ed3ebb /Tests/CMakeLists.txt
parent738a182a90dd29ce16376ab03a08c718b8068867 (diff)
downloadCMake-027ce359ff7454ac0aca4d9a9208759ef4b9c8b7.zip
CMake-027ce359ff7454ac0aca4d9a9208759ef4b9c8b7.tar.gz
CMake-027ce359ff7454ac0aca4d9a9208759ef4b9c8b7.tar.bz2
FindOpenGL: Provide imported targets for GL and GLU
Create OpenGL::GL and OpenGL::GLU imported targets using the locations found. This feature was originally added by commit v3.1.0-rc1~420^2~2 (FindOpenGL: Provide imported targets for GL and GLU, 2014-05-31) but had to be reverted by commit v3.1.0-rc3~10^2 (FindOpenGL: Revert support for imported targets, 2014-12-01) due to issue #15267. Since then we added support for `IMPORTED_LIBNAME` to interface libraries, so use it to handle the case where we have only the library name without an absolute path. Inspired-by: Philipp Möller <bootsarehax@googlemail.com> Closes: #15267
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index fa5f3e8..73eef9a 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1400,6 +1400,10 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
add_subdirectory(FindOpenCL)
endif()
+ if(CMake_TEST_FindOpenGL)
+ add_subdirectory(FindOpenGL)
+ endif()
+
if(CMake_TEST_FindOpenSSL)
add_subdirectory(FindOpenSSL)
endif()