summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorRolf Eike Beer <eike@sf-mail.de>2012-09-21 15:37:08 (GMT)
committerRolf Eike Beer <kde@opensource.sf-tec.de>2014-01-14 22:57:40 (GMT)
commit3a0d164bb2fa03966cdd7a17c0ce63b4d54f05b7 (patch)
tree859a1201b9ef9d4919b5ef86ff837ecfc1f5c587 /Tests/CMakeLists.txt
parent31e1c39c57d61c208443973b38a4eb6f7f7d187f (diff)
downloadCMake-3a0d164bb2fa03966cdd7a17c0ce63b4d54f05b7.zip
CMake-3a0d164bb2fa03966cdd7a17c0ce63b4d54f05b7.tar.gz
CMake-3a0d164bb2fa03966cdd7a17c0ce63b4d54f05b7.tar.bz2
allow to mark a test as "Not Run" with a specific return code (#8466)
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 7969078..a79111a 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2230,6 +2230,18 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
--output-log "${CMake_BINARY_DIR}/Tests/CTestTestParallel/testOutput.log"
)
+ configure_file(
+ "${CMake_SOURCE_DIR}/Tests/CTestTestSkipReturnCode/test.cmake.in"
+ "${CMake_BINARY_DIR}/Tests/CTestTestSkipReturnCode/test.cmake"
+ @ONLY ESCAPE_QUOTES)
+ add_test(CTestTestSkipReturnCode ${CMAKE_CTEST_COMMAND}
+ -S "${CMake_BINARY_DIR}/Tests/CTestTestSkipReturnCode/test.cmake" -V
+ --output-log "${CMake_BINARY_DIR}/Tests/CTestTestSkipReturnCode/testOutput.log"
+ -C \${CTEST_CONFIGURATION_TYPE}
+ )
+ set_tests_properties(CTestTestSkipReturnCode PROPERTIES
+ PASS_REGULAR_EXPRESSION "CMakeV1 \\.* +Passed.*CMakeV2 \\.+\\*+Skipped")
+
ADD_TEST_MACRO(CTestTestSerialInDepends ${CMAKE_CTEST_COMMAND} -j 4
--output-on-failure -C "\${CTestTest_CONFIG}")