summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-09-29 20:39:43 (GMT)
committerBrad King <brad.king@kitware.com>2009-09-29 20:39:43 (GMT)
commit0db2c8505e3236c37d500c2d4afb9efbc675fdfc (patch)
treececdd7a7075376df272cb0c7d083a49ff399319a /Tests/CMakeLists.txt
parent024d05adada5b9deaac84f0f4df8beed273c972a (diff)
downloadCMake-0db2c8505e3236c37d500c2d4afb9efbc675fdfc.zip
CMake-0db2c8505e3236c37d500c2d4afb9efbc675fdfc.tar.gz
CMake-0db2c8505e3236c37d500c2d4afb9efbc675fdfc.tar.bz2
Test use of module .def files for MS tools
This adds a "ModuleDefinition" test enabled when using MSVC tools. It checks that .def files can be used to export .dll and .exe symbols and create corresponding .lib files that can be linked. See issue #9613.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 2f5980d..4fdd286 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -846,6 +846,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=CVS -P ${CMake_SOURCE_DIR}/Utilities/Rel
IF(CMAKE_TEST_MSVC)
ADD_TEST_MACRO(PrecompiledHeader foo)
+ ADD_TEST_MACRO(ModuleDefinition example_exe)
ENDIF(CMAKE_TEST_MSVC)
IF("${CMAKE_TEST_GENERATOR}" MATCHES "Makefile")