summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorPatrick Gansterer <paroga@paroga.com>2013-07-28 18:34:16 (GMT)
committerBrad King <brad.king@kitware.com>2013-07-31 12:41:08 (GMT)
commit152dfdab11f66f4675c7f9af1cff6d301b1e271a (patch)
tree98d9f6e78ecd7926c881a55b5fbeebd72f1aaf93 /Tests/CMakeLists.txt
parent20ed496b6d98bd2e28c2657c3383dd0cdbae9f4d (diff)
downloadCMake-152dfdab11f66f4675c7f9af1cff6d301b1e271a.zip
CMake-152dfdab11f66f4675c7f9af1cff6d301b1e271a.tar.gz
CMake-152dfdab11f66f4675c7f9af1cff6d301b1e271a.tar.bz2
Add additonal tests for the linker flags
Extend Tests/LinkFlags to test libraries of the type MODULE and the content of the CMAKE_*_LINKER_FLAGS_* variables.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 440cdf0..16693de 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -394,10 +394,20 @@ if(BUILD_TESTING)
endmacro()
ADD_LINK_FLAGS_TEST(lib prepare)
ADD_LINK_FLAGS_TEST(dll lib)
- ADD_LINK_FLAGS_TEST(exe dll)
+ ADD_LINK_FLAGS_TEST(mod dll)
+ ADD_LINK_FLAGS_TEST(exe mod)
ADD_LINK_FLAGS_TEST(lib_config exe)
ADD_LINK_FLAGS_TEST(dll_config lib_config)
- ADD_LINK_FLAGS_TEST(exe_config dll_config)
+ ADD_LINK_FLAGS_TEST(mod_config dll_config)
+ ADD_LINK_FLAGS_TEST(exe_config mod_config)
+ ADD_LINK_FLAGS_TEST(lib_flags exe_config)
+ ADD_LINK_FLAGS_TEST(dll_flags lib_flags)
+ ADD_LINK_FLAGS_TEST(mod_flags dll_flags)
+ ADD_LINK_FLAGS_TEST(exe_flags mod_flags)
+ ADD_LINK_FLAGS_TEST(lib_flags_config exe_flags)
+ ADD_LINK_FLAGS_TEST(dll_flags_config lib_flags_config)
+ ADD_LINK_FLAGS_TEST(mod_flags_config dll_flags_config)
+ ADD_LINK_FLAGS_TEST(exe_flags_config mod_flags_config)
# If we are running right now with a UnixMakefiles based generator,
# build the "Simple" test with the ExtraGenerators, if available