summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-06-03 17:51:31 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2013-06-03 17:51:31 (GMT)
commitc9be17c8609c6f84c75710be917e23c59ecdb316 (patch)
tree3129c40a22f8808ff5cf8bfe1d78273d79564878 /Tests/CMakeLists.txt
parentd114fc373c1499689265c6c12e95b86f2930b227 (diff)
parente4e09212c58995a6cfde7d101bc02fce0f7829be (diff)
downloadCMake-c9be17c8609c6f84c75710be917e23c59ecdb316.zip
CMake-c9be17c8609c6f84c75710be917e23c59ecdb316.tar.gz
CMake-c9be17c8609c6f84c75710be917e23c59ecdb316.tar.bz2
Merge topic 'escape-regex-specials-in-path'
e4e0921 Merge branch 'master' into escape-regex-specials-in-path c9b75dc Fix test failures caused by regexp-sensitive characters in the build paths
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index ee6c3e6..9d4f3b8 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -15,10 +15,7 @@ macro(ADD_TEST_MACRO NAME COMMAND)
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/${dir}")
endmacro()
-macro(REGEX_ESCAPE_STRING _OUT _IN)
- # Escape special regex metacharacters with a backslash
- string(REGEX REPLACE "([$^.[|*+?()]|])" "\\\\\\1" ${_OUT} "${_IN}")
-endmacro()
+include(${CMAKE_CURRENT_SOURCE_DIR}/RegexEscapeString.cmake)
include(${CMAKE_CURRENT_SOURCE_DIR}/CheckFortran.cmake)