summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorZach Mullen <zach.mullen@kitware.com>2009-11-10 15:40:24 (GMT)
committerZach Mullen <zach.mullen@kitware.com>2009-11-10 15:40:24 (GMT)
commitc9c0ee4056aa651a63ee6c34abb06e60e987dbe3 (patch)
tree869a02a81b1ff9cc2790bd73290030d743fac854 /Tests/CMakeLists.txt
parent21a59bdc4d4c54af5cd175561f9249d5932434d2 (diff)
downloadCMake-c9c0ee4056aa651a63ee6c34abb06e60e987dbe3.zip
CMake-c9c0ee4056aa651a63ee6c34abb06e60e987dbe3.tar.gz
CMake-c9c0ee4056aa651a63ee6c34abb06e60e987dbe3.tar.bz2
Change logic of ctest subdirs command to allow for absolute paths. Also added test coverage for passing absolute paths to subdirs.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 7552e78..400cfdd 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1210,6 +1210,9 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=CVS -P ${CMake_SOURCE_DIR}/Utilities/Rel
-S "${CMake_BINARY_DIR}/Tests/CTestTestSubdir/test.cmake" -V
--output-log "${CMake_BINARY_DIR}/Tests/CTestTestSubdir/testOutput.log"
)
+ #make sure all 3 subdirs were added
+ SET_TESTS_PROPERTIES(CTestTestSubdir PROPERTIES
+ PASS_REGULAR_EXPRESSION "0 tests failed out of 3")
CONFIGURE_FILE(
"${CMake_SOURCE_DIR}/Tests/CTestTestTimeout/test.cmake.in"