summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeOnly/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2012-01-12 15:22:00 (GMT)
committerBrad King <brad.king@kitware.com>2012-01-13 19:22:24 (GMT)
commit8e756d2b9bb84b182a8402e71fb62d7a28d0a9c6 (patch)
treee4e630efbc1b9078cb2d23e38b67026d13ea0df4 /Tests/CMakeOnly/CMakeLists.txt
parent9a20abf04a7fc11b53beb545f1555fe9815ae09c (diff)
downloadCMake-8e756d2b9bb84b182a8402e71fb62d7a28d0a9c6.zip
CMake-8e756d2b9bb84b182a8402e71fb62d7a28d0a9c6.tar.gz
CMake-8e756d2b9bb84b182a8402e71fb62d7a28d0a9c6.tar.bz2
Tolerate cycles in shared library link interfaces (#12647)
Since commit 183b9509 (Follow all dependencies of shared library private dependencies, 2011-12-14) we honor LINK_INTERFACE_LIBRARIES when following dependent shared libraries. The link interface properties may form a cycle if set incorrectly by a project. Furthermore, the property LINK_DEPENDENT_LIBRARIES may form a cycle if set incorrectly by hand (though CMake should never generate one). In either case, do not follow the cycle forever when following the dependent shared library closure. We only need to add dependency edges to the constraint graph once. Add "LinkInterfaceLoop" test to cover this case.
Diffstat (limited to 'Tests/CMakeOnly/CMakeLists.txt')
-rw-r--r--Tests/CMakeOnly/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeOnly/CMakeLists.txt b/Tests/CMakeOnly/CMakeLists.txt
index d32e7be..e4ba53a 100644
--- a/Tests/CMakeOnly/CMakeLists.txt
+++ b/Tests/CMakeOnly/CMakeLists.txt
@@ -7,3 +7,6 @@ macro(add_CMakeOnly_test test)
-P ${CMAKE_CURRENT_BINARY_DIR}/Test.cmake
)
endmacro()
+
+add_CMakeOnly_test(LinkInterfaceLoop)
+set_property(TEST CMakeOnly.LinkInterfaceLoop PROPERTY TIMEOUT 90)