summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeOnly/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-04-03 19:38:26 (GMT)
committerBrad King <brad.king@kitware.com>2017-04-03 20:04:17 (GMT)
commitfe21ccc4860d38bdb80f4dc8a0785661484e7024 (patch)
tree7f226adcf34f5003cf3b01ae481acea495f1e06c /Tests/CMakeOnly/CMakeLists.txt
parent53e9c2d2a31f33f5d72c2df5558ffa7213a54a04 (diff)
downloadCMake-fe21ccc4860d38bdb80f4dc8a0785661484e7024.zip
CMake-fe21ccc4860d38bdb80f4dc8a0785661484e7024.tar.gz
CMake-fe21ccc4860d38bdb80f4dc8a0785661484e7024.tar.bz2
Tests: Optionally skip local packages versions in CMakeOnly.AllFindModules
Some machines have incomplete or otherwise broken installations of specific packages. Allow local configuration to prevent the test from failing on such packages if the version number cannot be extracted.
Diffstat (limited to 'Tests/CMakeOnly/CMakeLists.txt')
-rw-r--r--Tests/CMakeOnly/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/Tests/CMakeOnly/CMakeLists.txt b/Tests/CMakeOnly/CMakeLists.txt
index d44c836..2b25766 100644
--- a/Tests/CMakeOnly/CMakeLists.txt
+++ b/Tests/CMakeOnly/CMakeLists.txt
@@ -37,7 +37,11 @@ if(CMAKE_GENERATOR MATCHES "Visual Studio ([^789]|[789][0-9])")
add_CMakeOnly_test(CompilerIdCSharp)
endif()
-add_CMakeOnly_test(AllFindModules)
+add_test(CMakeOnly.AllFindModules ${CMAKE_CMAKE_COMMAND}
+ -DTEST=AllFindModules
+ -DCMAKE_ARGS=-DCMake_TEST_CMakeOnly.AllFindModules_NO_VERSION=${CMake_TEST_CMakeOnly.AllFindModules_NO_VERSION}
+ -P ${CMAKE_CURRENT_BINARY_DIR}/Test.cmake
+ )
add_CMakeOnly_test(SelectLibraryConfigurations)