summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeOnly/CMakeLists.txt
diff options
context:
space:
mode:
authorRuslan Baratov <ruslan_baratov@yahoo.com>2019-03-28 19:43:40 (GMT)
committerRuslan Baratov <ruslan_baratov@yahoo.com>2019-04-01 17:30:19 (GMT)
commit076118694995c19de7637156322818f3994de76a (patch)
tree232852f10182ebbc3773e7ee122c058dd8ff7aa1 /Tests/CMakeOnly/CMakeLists.txt
parent3e129d71bc12a325c0548aaaea24470cd172470b (diff)
downloadCMake-076118694995c19de7637156322818f3994de76a.zip
CMake-076118694995c19de7637156322818f3994de76a.tar.gz
CMake-076118694995c19de7637156322818f3994de76a.tar.bz2
project: Add variable CMAKE_PROJECT_INCLUDE_BEFORE
Diffstat (limited to 'Tests/CMakeOnly/CMakeLists.txt')
-rw-r--r--Tests/CMakeOnly/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Tests/CMakeOnly/CMakeLists.txt b/Tests/CMakeOnly/CMakeLists.txt
index 57f0cf8..1aeab8b 100644
--- a/Tests/CMakeOnly/CMakeLists.txt
+++ b/Tests/CMakeOnly/CMakeLists.txt
@@ -62,6 +62,12 @@ add_test(CMakeOnly.ProjectIncludeAny ${CMAKE_CMAKE_COMMAND}
-P ${CMAKE_CURRENT_BINARY_DIR}/Test.cmake
)
+add_test(CMakeOnly.ProjectIncludeBefore ${CMAKE_CMAKE_COMMAND}
+ -DTEST=ProjectIncludeBefore
+ -DCMAKE_ARGS=-DCMAKE_PROJECT_INCLUDE_BEFORE=${CMAKE_CURRENT_SOURCE_DIR}/ProjectIncludeBefore/include.cmake
+ -P ${CMAKE_CURRENT_BINARY_DIR}/Test.cmake
+ )
+
include(CMakeParseArguments)
function(add_major_test module)