summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeOnly/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2012-02-08 15:48:34 (GMT)
committerBrad King <brad.king@kitware.com>2012-02-08 15:48:34 (GMT)
commit5db99e8708c7d329620186e4cfb6e059f400dfcc (patch)
tree033ea7ef29feb3b8f59abc3607375765f437b4c6 /Tests/CMakeOnly/CMakeLists.txt
parent7dcfd9aaf621672b3006fd5b084a17409d4435b2 (diff)
downloadCMake-5db99e8708c7d329620186e4cfb6e059f400dfcc.zip
CMake-5db99e8708c7d329620186e4cfb6e059f400dfcc.tar.gz
CMake-5db99e8708c7d329620186e4cfb6e059f400dfcc.tar.bz2
Add CheckLanguage module
Define a "check_language(<lang>)" macro to test whether <lang> can be enabled. Cache the result in CMAKE_<lang>_COMPILER. Add a test case covering expected results.
Diffstat (limited to 'Tests/CMakeOnly/CMakeLists.txt')
-rw-r--r--Tests/CMakeOnly/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/CMakeOnly/CMakeLists.txt b/Tests/CMakeOnly/CMakeLists.txt
index 33c426a..4407efb 100644
--- a/Tests/CMakeOnly/CMakeLists.txt
+++ b/Tests/CMakeOnly/CMakeLists.txt
@@ -17,6 +17,8 @@ add_CMakeOnly_test(CheckCXXSymbolExists)
add_CMakeOnly_test(CheckCXXCompilerFlag)
+add_CMakeOnly_test(CheckLanguage)
+
add_CMakeOnly_test(AllFindModules)
add_CMakeOnly_test(TargetScope)