summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeOnly/CMakeLists.txt
diff options
context:
space:
mode:
authorSteve Wilson <stevew@wolfram.com>2019-09-13 17:12:15 (GMT)
committerCristian Adam <cristian.adam@gmail.com>2019-09-28 13:56:53 (GMT)
commit9e66397c28110f015e5b044dfe9782cd5f11c8c3 (patch)
tree6febffa635898ae983996eb6fbc8b8875d80fb2d /Tests/CMakeOnly/CMakeLists.txt
parent80f120a85fb0992e3f06ad69ebdad881bea9af8c (diff)
downloadCMake-9e66397c28110f015e5b044dfe9782cd5f11c8c3.zip
CMake-9e66397c28110f015e5b044dfe9782cd5f11c8c3.tar.gz
CMake-9e66397c28110f015e5b044dfe9782cd5f11c8c3.tar.bz2
Languages: Add support for Objective-C++
Add entries in Modules and Modules/Platform to support Objective-C++ compiler determination and identification. Add Modules to check Objective-C++ compiler flags, source compilations, program checks, etc... Use OBJCXX as the designator of the language, eg: project(foo OBJCXX) Add various tests for Objective-C++ language features. Add tests to preserve C++ handling of .M and .mm files when Objective-C++ is not a configured language. Co-authored-by: Cristian Adam <cristian.adam@gmail.com>
Diffstat (limited to 'Tests/CMakeOnly/CMakeLists.txt')
-rw-r--r--Tests/CMakeOnly/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tests/CMakeOnly/CMakeLists.txt b/Tests/CMakeOnly/CMakeLists.txt
index 1a25469..03babd2 100644
--- a/Tests/CMakeOnly/CMakeLists.txt
+++ b/Tests/CMakeOnly/CMakeLists.txt
@@ -36,6 +36,11 @@ if(CMAKE_OBJC_COMPILER)
add_CMakeOnly_test(CheckOBJCCompilerFlag)
endif()
+if(CMAKE_OBJCXX_COMPILER)
+ add_CMakeOnly_test(CompilerIdOBJCXX)
+ add_CMakeOnly_test(CheckOBJCXXCompilerFlag)
+endif()
+
if(CMAKE_Fortran_COMPILER)
add_CMakeOnly_test(CompilerIdFortran)
endif()