summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeOnly/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Maynard <robert.maynard@kitware.com>2020-09-24 19:31:55 (GMT)
committerBrad King <brad.king@kitware.com>2020-10-08 12:30:59 (GMT)
commitda2622ff366e6089a98109c68ececac58d598b66 (patch)
tree8205c6455c1c996ccb39d6270b8de385a92e78bb /Tests/CMakeOnly/CMakeLists.txt
parentc61f820a7fb1b191fe5591805f7e53fc52424f93 (diff)
downloadCMake-da2622ff366e6089a98109c68ececac58d598b66.zip
CMake-da2622ff366e6089a98109c68ececac58d598b66.tar.gz
CMake-da2622ff366e6089a98109c68ececac58d598b66.tar.bz2
CUDA: Add Support to SourceCompiles|Runs and CheckCompilerFlags
Diffstat (limited to 'Tests/CMakeOnly/CMakeLists.txt')
-rw-r--r--Tests/CMakeOnly/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tests/CMakeOnly/CMakeLists.txt b/Tests/CMakeOnly/CMakeLists.txt
index 361cf5f..a41b44e 100644
--- a/Tests/CMakeOnly/CMakeLists.txt
+++ b/Tests/CMakeOnly/CMakeLists.txt
@@ -38,6 +38,11 @@ if (APPLE AND CMAKE_C_COMPILER_ID MATCHES "Clang|GNU")
add_CMakeOnly_test(CheckOBJCXXCompilerFlag)
endif()
+if(CMake_TEST_CUDA)
+ add_CMakeOnly_test(CompilerIdCUDA)
+endif()
+
+
if(CMAKE_Fortran_COMPILER)
add_CMakeOnly_test(CompilerIdFortran)
endif()