summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeOnly/ProjectInclude/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2012-03-02 16:49:35 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2012-03-02 16:49:35 (GMT)
commit1073d50508aa384984b9ea6200863855237ad4a1 (patch)
treeb41d7b7c158bd939b75d6137bb9fb50daa2004c6 /Tests/CMakeOnly/ProjectInclude/CMakeLists.txt
parent20446079eebe5cf734f673071efd0d1b56a02a61 (diff)
parent2557a080543a37f92e1908420842db8c90685304 (diff)
downloadCMake-1073d50508aa384984b9ea6200863855237ad4a1.zip
CMake-1073d50508aa384984b9ea6200863855237ad4a1.tar.gz
CMake-1073d50508aa384984b9ea6200863855237ad4a1.tar.bz2
Merge topic 'inject_code_via_variable'
2557a08 Fix typo in error message, and remove redundent test. 9090572 Add ability to include a file in a project via a cache variable.
Diffstat (limited to 'Tests/CMakeOnly/ProjectInclude/CMakeLists.txt')
-rw-r--r--Tests/CMakeOnly/ProjectInclude/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CMakeOnly/ProjectInclude/CMakeLists.txt b/Tests/CMakeOnly/ProjectInclude/CMakeLists.txt
new file mode 100644
index 0000000..a9abb4a
--- /dev/null
+++ b/Tests/CMakeOnly/ProjectInclude/CMakeLists.txt
@@ -0,0 +1,4 @@
+project(ProjectInclude)
+if(NOT AUTO_INCLUDE)
+ message(FATAL_ERROR "include file not found")
+endif()