summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeServerLib/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin Berger <j.david.berger@gmail.com>2017-07-22 23:23:11 (GMT)
committerBrad King <brad.king@kitware.com>2017-08-31 19:35:04 (GMT)
commitdc7a18d82eb0013a2afbdea9ba5fec131fc3179f (patch)
treeece5cf570b60a21caf772cc20576f097e0520a83 /Tests/CMakeServerLib/CMakeLists.txt
parentf8fd5a979cb4acd8a37632c29b453a426e798178 (diff)
downloadCMake-dc7a18d82eb0013a2afbdea9ba5fec131fc3179f.zip
CMake-dc7a18d82eb0013a2afbdea9ba5fec131fc3179f.tar.gz
CMake-dc7a18d82eb0013a2afbdea9ba5fec131fc3179f.tar.bz2
server: test buffer parsing
Diffstat (limited to 'Tests/CMakeServerLib/CMakeLists.txt')
-rw-r--r--Tests/CMakeServerLib/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/Tests/CMakeServerLib/CMakeLists.txt b/Tests/CMakeServerLib/CMakeLists.txt
new file mode 100644
index 0000000..f5351fd
--- /dev/null
+++ b/Tests/CMakeServerLib/CMakeLists.txt
@@ -0,0 +1,17 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMake_BINARY_DIR}/Source
+ ${CMake_SOURCE_DIR}/Source
+ )
+
+set(CMakeServerLib_TESTS
+ testServerBuffering
+ )
+
+create_test_sourcelist(CMakeLib_TEST_SRCS CMakeServerLibTests.cxx ${CMakeServerLib_TESTS})
+add_executable(CMakeServerLibTests ${CMakeLib_TEST_SRCS})
+target_link_libraries(CMakeServerLibTests CMakeLib CMakeServerLib)
+
+foreach(test ${CMakeServerLib_TESTS})
+ add_test(CMakeServerLib.${test} CMakeServerLibTests ${test} ${${test}_ARGS})
+endforeach()