summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeServerLib/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin Berger <j.david.berger@gmail.com>2017-11-10 03:52:32 (GMT)
committerBrad King <brad.king@kitware.com>2017-11-29 21:36:31 (GMT)
commitf43b9219c738944fea33043b1985696c862c84ac (patch)
tree706681eddd9764a47a00ead69fec27c22f61b6f9 /Tests/CMakeServerLib/CMakeLists.txt
parenta3abb85c6ff5aebe2220ae612512a434b491eedd (diff)
downloadCMake-f43b9219c738944fea33043b1985696c862c84ac.zip
CMake-f43b9219c738944fea33043b1985696c862c84ac.tar.gz
CMake-f43b9219c738944fea33043b1985696c862c84ac.tar.bz2
tests: Added tests to verify UV RAII semantics/constructs
Diffstat (limited to 'Tests/CMakeServerLib/CMakeLists.txt')
-rw-r--r--Tests/CMakeServerLib/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CMakeServerLib/CMakeLists.txt b/Tests/CMakeServerLib/CMakeLists.txt
index f5351fd..f1ca2a4 100644
--- a/Tests/CMakeServerLib/CMakeLists.txt
+++ b/Tests/CMakeServerLib/CMakeLists.txt
@@ -6,12 +6,16 @@ include_directories(
set(CMakeServerLib_TESTS
testServerBuffering
+ testUVRAII
)
create_test_sourcelist(CMakeLib_TEST_SRCS CMakeServerLibTests.cxx ${CMakeServerLib_TESTS})
add_executable(CMakeServerLibTests ${CMakeLib_TEST_SRCS})
target_link_libraries(CMakeServerLibTests CMakeLib CMakeServerLib)
+SET_PROPERTY(TARGET CMakeServerLibTests PROPERTY C_CLANG_TIDY "")
+SET_PROPERTY(TARGET CMakeServerLibTests PROPERTY CXX_CLANG_TIDY "")
+
foreach(test ${CMakeServerLib_TESTS})
add_test(CMakeServerLib.${test} CMakeServerLibTests ${test} ${${test}_ARGS})
endforeach()