summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeServerLib/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-11-30 15:57:43 (GMT)
committerKitware Robot <kwrobot@kitware.com>2017-11-30 15:57:52 (GMT)
commit92b212e87542552a8dd095608098609a3ebe1d6d (patch)
tree16787e74a21534590493b7237271aeba2443b27d /Tests/CMakeServerLib/CMakeLists.txt
parentc2ea729c87cee2fb19d34090ef00e42d12fb59f2 (diff)
parent1e9b7d3ceb882d3feb59324b6e55d40cc795576b (diff)
downloadCMake-92b212e87542552a8dd095608098609a3ebe1d6d.zip
CMake-92b212e87542552a8dd095608098609a3ebe1d6d.tar.gz
CMake-92b212e87542552a8dd095608098609a3ebe1d6d.tar.bz2
Merge topic 'libuv-raii'
1e9b7d3c server: Switched to a auto model for handles f43b9219 tests: Added tests to verify UV RAII semantics/constructs a3abb85c Add RAII handles for libuv handle types 90f8db26 tests: unconditionally enabled server tests b56b51fc utility: Disabled copy ctors in thread classes Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !1453
Diffstat (limited to 'Tests/CMakeServerLib/CMakeLists.txt')
-rw-r--r--Tests/CMakeServerLib/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CMakeServerLib/CMakeLists.txt b/Tests/CMakeServerLib/CMakeLists.txt
index f5351fd..f1ca2a4 100644
--- a/Tests/CMakeServerLib/CMakeLists.txt
+++ b/Tests/CMakeServerLib/CMakeLists.txt
@@ -6,12 +6,16 @@ include_directories(
set(CMakeServerLib_TESTS
testServerBuffering
+ testUVRAII
)
create_test_sourcelist(CMakeLib_TEST_SRCS CMakeServerLibTests.cxx ${CMakeServerLib_TESTS})
add_executable(CMakeServerLibTests ${CMakeLib_TEST_SRCS})
target_link_libraries(CMakeServerLibTests CMakeLib CMakeServerLib)
+SET_PROPERTY(TARGET CMakeServerLibTests PROPERTY C_CLANG_TIDY "")
+SET_PROPERTY(TARGET CMakeServerLibTests PROPERTY CXX_CLANG_TIDY "")
+
foreach(test ${CMakeServerLib_TESTS})
add_test(CMakeServerLib.${test} CMakeServerLibTests ${test} ${${test}_ARGS})
endforeach()