summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeTests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-10-27 13:08:12 (GMT)
committerBrad King <brad.king@kitware.com>2009-10-27 13:08:12 (GMT)
commit6bf98dba014f72b62d4f3a24affb279cca9e4d15 (patch)
tree805b229697faf152067731b56aa9e5419ff6393e /Tests/CMakeTests/CMakeLists.txt
parentcb185d93d29d27eaafd321f657f4ba12d9beaeb8 (diff)
downloadCMake-6bf98dba014f72b62d4f3a24affb279cca9e4d15.zip
CMake-6bf98dba014f72b62d4f3a24affb279cca9e4d15.tar.gz
CMake-6bf98dba014f72b62d4f3a24affb279cca9e4d15.tar.bz2
Test if() boolean coersion and CMP0012 behaviors
We introduce the "CMake.If" test to try out conversion of constants and variables to boolean values in the if() command. We cover both OLD and NEW behavior for policy CMP0012.
Diffstat (limited to 'Tests/CMakeTests/CMakeLists.txt')
-rw-r--r--Tests/CMakeTests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeTests/CMakeLists.txt b/Tests/CMakeTests/CMakeLists.txt
index 456e2e9..1b768cf 100644
--- a/Tests/CMakeTests/CMakeLists.txt
+++ b/Tests/CMakeTests/CMakeLists.txt
@@ -22,6 +22,7 @@ AddCMakeTest(ConfigureFile "")
AddCMakeTest(SeparateArguments "")
AddCMakeTest(ImplicitLinkInfo "")
AddCMakeTest(ModuleNotices "")
+AddCMakeTest(If "")
AddCMakeTest(String "")
AddCMakeTest(Math "")
AddCMakeTest(CMakeMinimumRequired "")