summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeTests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-04-29 17:13:58 (GMT)
committerBrad King <brad.king@kitware.com>2009-04-29 17:13:58 (GMT)
commite0d3339e655049cc44e27861a5c65ce0dc2ef39a (patch)
treed723fdf56d25e225a701da5c51030bc65f7cad08 /Tests/CMakeTests/CMakeLists.txt
parentc58ca242865118d65b5add11a256832d177afe6d (diff)
downloadCMake-e0d3339e655049cc44e27861a5c65ce0dc2ef39a.zip
CMake-e0d3339e655049cc44e27861a5c65ce0dc2ef39a.tar.gz
CMake-e0d3339e655049cc44e27861a5c65ce0dc2ef39a.tar.bz2
ENH: Test file(COPY) failure cases
This tests some cases of bad arguments to the file(COPY) signature. It checks that the proper error messages are produced.
Diffstat (limited to 'Tests/CMakeTests/CMakeLists.txt')
-rw-r--r--Tests/CMakeTests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeTests/CMakeLists.txt b/Tests/CMakeTests/CMakeLists.txt
index e197302..62e6133 100644
--- a/Tests/CMakeTests/CMakeLists.txt
+++ b/Tests/CMakeTests/CMakeLists.txt
@@ -17,6 +17,7 @@ AddCMakeTest(Toolchain "")
AddCMakeTest(GetFilenameComponentRealpath "")
AddCMakeTest(Version "")
AddCMakeTest(Message "")
+AddCMakeTest(File "")
SET(GetPrerequisites_PreArgs
"-DCTEST_CONFIGURATION_TYPE:STRING=\\\${CTEST_CONFIGURATION_TYPE}"