summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeTests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-03-31 19:20:01 (GMT)
committerBrad King <brad.king@kitware.com>2017-04-03 14:45:03 (GMT)
commitc2c22862287971035157fb732faf925df7832dbb (patch)
tree42cd9504294544f70b90f8be89f6967bcaa0b240 /Tests/CMakeTests/CMakeLists.txt
parentc791fb12544926bc5870a61735dc2ec62940a6f6 (diff)
downloadCMake-c2c22862287971035157fb732faf925df7832dbb.zip
CMake-c2c22862287971035157fb732faf925df7832dbb.tar.gz
CMake-c2c22862287971035157fb732faf925df7832dbb.tar.bz2
Tests: Fix CMake.GetPrerequisites test config message
Since commit v2.8.11~239^2~1 (ProcessorCount test: fix path to cmsysTestsCxx executable, 2013-01-24) we accidentally printed a literal `${CTEST_CONFIGURATION_TYPE}` instead of the actual build configuration. Update the message to use a generator expression to get the real build configuration used.
Diffstat (limited to 'Tests/CMakeTests/CMakeLists.txt')
-rw-r--r--Tests/CMakeTests/CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/Tests/CMakeTests/CMakeLists.txt b/Tests/CMakeTests/CMakeLists.txt
index d5524c3..1cca35d 100644
--- a/Tests/CMakeTests/CMakeLists.txt
+++ b/Tests/CMakeTests/CMakeLists.txt
@@ -53,10 +53,7 @@ set(EndStuff_PreArgs
)
AddCMakeTest(EndStuff "${EndStuff_PreArgs}")
-set(GetPrerequisites_PreArgs
- "-DCTEST_CONFIGURATION_TYPE:STRING=\\\${CTEST_CONFIGURATION_TYPE}"
- )
-AddCMakeTest(GetPrerequisites "${GetPrerequisites_PreArgs}")
+AddCMakeTest(GetPrerequisites "-DConfiguration:STRING=$<CONFIGURATION>")
if(GIT_EXECUTABLE)
set(PolicyCheck_PreArgs