summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeTests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-07-14 14:15:47 (GMT)
committerBrad King <brad.king@kitware.com>2009-07-14 14:15:47 (GMT)
commitb23b1800a586b0afb316f92d9bde82896c804ef5 (patch)
treef58cf1b529d826c3801939b6c9cb762e66950039 /Tests/CMakeTests/CMakeLists.txt
parent7a907f87f8a7ec08f8d402dd2fafd2a189e81bbc (diff)
downloadCMake-b23b1800a586b0afb316f92d9bde82896c804ef5.zip
CMake-b23b1800a586b0afb316f92d9bde82896c804ef5.tar.gz
CMake-b23b1800a586b0afb316f92d9bde82896c804ef5.tar.bz2
ENH: Teach separate_arguments() to parse commands
This adds UNIX_COMMAND and WINDOWS_COMMAND modes to the command. These modes parse unix- and windows-style command lines.
Diffstat (limited to 'Tests/CMakeTests/CMakeLists.txt')
-rw-r--r--Tests/CMakeTests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeTests/CMakeLists.txt b/Tests/CMakeTests/CMakeLists.txt
index 62e6133..b83518b 100644
--- a/Tests/CMakeTests/CMakeLists.txt
+++ b/Tests/CMakeTests/CMakeLists.txt
@@ -18,6 +18,7 @@ AddCMakeTest(GetFilenameComponentRealpath "")
AddCMakeTest(Version "")
AddCMakeTest(Message "")
AddCMakeTest(File "")
+AddCMakeTest(SeparateArguments "")
SET(GetPrerequisites_PreArgs
"-DCTEST_CONFIGURATION_TYPE:STRING=\\\${CTEST_CONFIGURATION_TYPE}"