summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeTests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-01-27 18:03:33 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2014-01-27 18:03:33 (GMT)
commit20263b719fd454f0e0c66b588510e18f0213ab68 (patch)
tree58d5a9884ff62b1ef77cee925d63e2449152eaa1 /Tests/CMakeTests/CMakeLists.txt
parentd31e68a26e6f854e90f3eab34d794a766227354d (diff)
parenta432b93b7919d34e37e202b0c992775a029928d3 (diff)
downloadCMake-20263b719fd454f0e0c66b588510e18f0213ab68.zip
CMake-20263b719fd454f0e0c66b588510e18f0213ab68.tar.gz
CMake-20263b719fd454f0e0c66b588510e18f0213ab68.tar.bz2
Merge topic 'robust-ep-download-verify'
a432b93b file DOWNLOAD: Display the curl result status when a hash mismatch occurs. 1cb9ef81 file DOWNLOAD: Test non-zero return status. f73f0fb3 file DOWNLOAD: Add test for bad hash. b5e2265f ExternalProject: Reattempt download when verification fails.
Diffstat (limited to 'Tests/CMakeTests/CMakeLists.txt')
-rw-r--r--Tests/CMakeTests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CMakeTests/CMakeLists.txt b/Tests/CMakeTests/CMakeLists.txt
index 41714f6..ce36830 100644
--- a/Tests/CMakeTests/CMakeLists.txt
+++ b/Tests/CMakeTests/CMakeLists.txt
@@ -38,6 +38,10 @@ AddCMakeTest(FileDownload "")
set_property(TEST CMake.FileDownload PROPERTY
PASS_REGULAR_EXPRESSION "file already exists with expected MD5 sum"
)
+AddCMakeTest(FileDownloadBadHash "")
+set_property(TEST CMake.FileDownloadBadHash PROPERTY
+ WILL_FAIL TRUE
+ )
AddCMakeTest(FileUpload "")