summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeTests/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2009-12-04 19:50:37 (GMT)
committerDavid Cole <david.cole@kitware.com>2009-12-04 19:50:37 (GMT)
commit8d28ce80290b639f34898b4ab62df469fe990ec4 (patch)
tree3e2fa43ae15d09a8a54a2e7b2b72a867a5f36585 /Tests/CMakeTests/CMakeLists.txt
parent700da5f2660ce4b85aa0ee89cbc01d1d2b6a5f3e (diff)
downloadCMake-8d28ce80290b639f34898b4ab62df469fe990ec4.zip
CMake-8d28ce80290b639f34898b4ab62df469fe990ec4.tar.gz
CMake-8d28ce80290b639f34898b4ab62df469fe990ec4.tar.bz2
Fix cvs password problems during the CMake.CheckSourceTree test. Make sure cvs has access to the original value of the HOME environment variable and not the 'CMake testing' value of it so that any cvs passwords set up on the machine work to get the list of local modifications using 'cvs up'...
Diffstat (limited to 'Tests/CMakeTests/CMakeLists.txt')
-rw-r--r--Tests/CMakeTests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeTests/CMakeLists.txt b/Tests/CMakeTests/CMakeLists.txt
index adaf247..6b44417 100644
--- a/Tests/CMakeTests/CMakeLists.txt
+++ b/Tests/CMakeTests/CMakeLists.txt
@@ -50,6 +50,7 @@ if(do_cvs_tests)
"-DCMake_BINARY_DIR:PATH=${CMake_BINARY_DIR}"
"-DCMake_SOURCE_DIR:PATH=${CMake_SOURCE_DIR}"
"-DCVS_EXECUTABLE:STRING=${CVS_EXECUTABLE}"
+ "-DHOME:STRING=$ENV{HOME}"
)
AddCMakeTest(CheckSourceTree "${CheckSourceTree_PreArgs}")
endif(do_cvs_tests)