summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeTests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2022-10-05 14:42:45 (GMT)
committerBrad King <brad.king@kitware.com>2022-10-05 16:38:12 (GMT)
commit8d453ee751e9610f8b4e0a1b1fd65cb3b080c3dc (patch)
treedc9d3bfdccc971eb555377d26c258dd843b96ed3 /Tests/CMakeTests/CMakeLists.txt
parentc23ebfa333208df8730a2c84635faf11fc7ad669 (diff)
downloadCMake-8d453ee751e9610f8b4e0a1b1fd65cb3b080c3dc.zip
CMake-8d453ee751e9610f8b4e0a1b1fd65cb3b080c3dc.tar.gz
CMake-8d453ee751e9610f8b4e0a1b1fd65cb3b080c3dc.tar.bz2
Tests: Improve CheckSourceTree test
Re-implement the test using simpler approach. Enable it only when doing an out-of-source build with a `.git` source. Run it last, serially. Re-use the `git` tool found for version computation. Print the output from `git status` without modification. Rely on `.gitignore` instead of filtering out paths ourselves.
Diffstat (limited to 'Tests/CMakeTests/CMakeLists.txt')
-rw-r--r--Tests/CMakeTests/CMakeLists.txt15
1 files changed, 0 insertions, 15 deletions
diff --git a/Tests/CMakeTests/CMakeLists.txt b/Tests/CMakeTests/CMakeLists.txt
index 9e0b891..bd2dd7e 100644
--- a/Tests/CMakeTests/CMakeLists.txt
+++ b/Tests/CMakeTests/CMakeLists.txt
@@ -59,18 +59,3 @@ if(GIT_EXECUTABLE)
)
AddCMakeTest(PolicyCheck "${PolicyCheck_PreArgs}")
endif()
-
-# Run CheckSourceTree as the very last test in the CMake/CTest/CPack test
-# suite. It detects if any changes have been made to the CMake source tree
-# by any previous configure, build or test steps.
-#
-if(GIT_EXECUTABLE)
- string(REPLACE "\\" "/" ENV_HOME "$ENV{HOME}")
- set(CheckSourceTree_PreArgs
- "-DCMake_BINARY_DIR:PATH=${CMake_BINARY_DIR}"
- "-DCMake_SOURCE_DIR:PATH=${CMake_SOURCE_DIR}"
- "-DGIT_EXECUTABLE:STRING=${GIT_EXECUTABLE}"
- "-DHOME:STRING=${ENV_HOME}"
- )
- AddCMakeTest(CheckSourceTree "${CheckSourceTree_PreArgs}")
-endif()