summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeTests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-10-27 18:01:31 (GMT)
committerBrad King <brad.king@kitware.com>2009-10-27 18:01:31 (GMT)
commit23bdb28cadcf3b9cfe474bec06e761fbe9f2d5a5 (patch)
treeb9d02a5bb7e3bda9a2e0b06842269ac45cc03d40 /Tests/CMakeTests/CMakeLists.txt
parent39e88bbe99ed608e8bfc73f8f7314640dd41e874 (diff)
downloadCMake-23bdb28cadcf3b9cfe474bec06e761fbe9f2d5a5.zip
CMake-23bdb28cadcf3b9cfe474bec06e761fbe9f2d5a5.tar.gz
CMake-23bdb28cadcf3b9cfe474bec06e761fbe9f2d5a5.tar.bz2
Create CMake.ELF test to cover cmELF further
This commit adds a CMake.ELF test to exercise cmELF and file(RPATH_*). We test all combinations of 32/64-bit and LSB/MSB binaries.
Diffstat (limited to 'Tests/CMakeTests/CMakeLists.txt')
-rw-r--r--Tests/CMakeTests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CMakeTests/CMakeLists.txt b/Tests/CMakeTests/CMakeLists.txt
index 1b768cf..adaf247 100644
--- a/Tests/CMakeTests/CMakeLists.txt
+++ b/Tests/CMakeTests/CMakeLists.txt
@@ -27,6 +27,10 @@ AddCMakeTest(String "")
AddCMakeTest(Math "")
AddCMakeTest(CMakeMinimumRequired "")
+if(HAVE_ELF_H)
+ AddCMakeTest(ELF "")
+endif()
+
SET(EndStuff_PreArgs
"-Ddir:STRING=${CMAKE_CURRENT_BINARY_DIR}/EndStuffTest"
)