summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeTests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2006-02-10 19:11:12 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2006-02-10 19:11:12 (GMT)
commitf87271d0eae52e6c670d10b53e72eed72e80bfd1 (patch)
treef5c7c2c35fd68be706db491c96422d545f409031 /Tests/CMakeTests/CMakeLists.txt
parentb8a33fb424aa28b710e0ec170814ac380ee057db (diff)
downloadCMake-f87271d0eae52e6c670d10b53e72eed72e80bfd1.zip
CMake-f87271d0eae52e6c670d10b53e72eed72e80bfd1.tar.gz
CMake-f87271d0eae52e6c670d10b53e72eed72e80bfd1.tar.bz2
ENH: Add initial implementation of the list command
Diffstat (limited to 'Tests/CMakeTests/CMakeLists.txt')
-rw-r--r--Tests/CMakeTests/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Tests/CMakeTests/CMakeLists.txt b/Tests/CMakeTests/CMakeLists.txt
new file mode 100644
index 0000000..a1eefb5
--- /dev/null
+++ b/Tests/CMakeTests/CMakeLists.txt
@@ -0,0 +1,10 @@
+SET(CMAKE_EXECUTABLE "${EXECUTABLE_OUTPUT_PATH}/cmake")
+
+
+MACRO(AddCMakeTest TestName Arguments)
+ CONFIGURE_FILE("${CMAKE_CURRENT_SOURCE_DIR}/${TestName}Test.cmake.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/${TestName}Test.cmake" @ONLY IMMEDIATE)
+ ADD_TEST(CMake.List ${CMAKE_EXECUTABLE} -P "${CMAKE_CURRENT_BINARY_DIR}/ListTest.cmake" ${Arguments})
+ENDMACRO(AddCMakeTest)
+
+AddCMakeTest(List "")