summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeTests/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2009-07-24 19:58:23 (GMT)
committerDavid Cole <david.cole@kitware.com>2009-07-24 19:58:23 (GMT)
commit5bea9620dcecea1ff252c688823485560bc6cab1 (patch)
treeb2f185b9ab43b05cff87f92b945b57abbe68f069 /Tests/CMakeTests/CMakeLists.txt
parent71c0e1417bdc42fbcc48986c7cb7c26642c1f665 (diff)
downloadCMake-5bea9620dcecea1ff252c688823485560bc6cab1.zip
CMake-5bea9620dcecea1ff252c688823485560bc6cab1.tar.gz
CMake-5bea9620dcecea1ff252c688823485560bc6cab1.tar.bz2
BUG: Additional fix necessary for issue #8481 so that Xcode builds do not write files into the source tree. Also add a test that runs last to check for local modifications in CMake_SOURCE_DIR based on whether 'cvs -q -n up -dP' output is empty. Test fails on dashboard runs when there are local modifications. Test passes on non-dashboard runs with local modifications so that CMake developers may have mods when running the test locally.
Diffstat (limited to 'Tests/CMakeTests/CMakeLists.txt')
-rw-r--r--Tests/CMakeTests/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Tests/CMakeTests/CMakeLists.txt b/Tests/CMakeTests/CMakeLists.txt
index 32c5412..a1962bf 100644
--- a/Tests/CMakeTests/CMakeLists.txt
+++ b/Tests/CMakeTests/CMakeLists.txt
@@ -25,3 +25,15 @@ SET(GetPrerequisites_PreArgs
"-DCTEST_CONFIGURATION_TYPE:STRING=\\\${CTEST_CONFIGURATION_TYPE}"
)
AddCMakeTest(GetPrerequisites "${GetPrerequisites_PreArgs}")
+
+# Run CheckSourceTree as the very last test in the CMake/CTest/CPack test
+# suite. It detects if any changes have been made to the CMake source tree
+# by any previous configure, build or test steps.
+#
+if(do_cvs_tests)
+ set(CheckSourceTree_PreArgs
+ "-DCMake_SOURCE_DIR:PATH=${CMake_SOURCE_DIR}"
+ "-DCVS_EXECUTABLE:STRING=${CVS_EXECUTABLE}"
+ )
+ AddCMakeTest(CheckSourceTree "${CheckSourceTree_PreArgs}")
+endif()