summaryrefslogtreecommitdiffstats
path: root/Tests/COnly/CMakeLists.txt
diff options
context:
space:
mode:
authorTushar Maheshwari <tushar27192@gmail.com>2019-08-27 16:58:34 (GMT)
committerTushar Maheshwari <tushar27192@gmail.com>2019-08-27 16:58:34 (GMT)
commit41ba3e28e6840fd560a537d400146d2cde67a239 (patch)
treeceeecdbd986e4b426c4a0aab2bcf40adaa599fac /Tests/COnly/CMakeLists.txt
parenta40744c81a8d6dad994def5a63103fc229a75afc (diff)
downloadCMake-41ba3e28e6840fd560a537d400146d2cde67a239.zip
CMake-41ba3e28e6840fd560a537d400146d2cde67a239.tar.gz
CMake-41ba3e28e6840fd560a537d400146d2cde67a239.tar.bz2
Tests: Collect SourceFileProperty tests
- Move the related test from COnly to SourceFileProperty - Cover `get_source_file_property` and `get_property(... SOURCE ...)`
Diffstat (limited to 'Tests/COnly/CMakeLists.txt')
-rw-r--r--Tests/COnly/CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/Tests/COnly/CMakeLists.txt b/Tests/COnly/CMakeLists.txt
index 3037f13..20615fe 100644
--- a/Tests/COnly/CMakeLists.txt
+++ b/Tests/COnly/CMakeLists.txt
@@ -13,11 +13,5 @@ if(MSVC_VERSION AND NOT CMAKE_C_COMPILER_ID STREQUAL Clang OR "x${CMAKE_C_COMPIL
endif()
string(ASCII 35 32 67 77 97 107 101 ASCII_STRING)
message(STATUS "String: ${ASCII_STRING}")
-get_source_file_property(LANG conly.c LANGUAGE)
-if("${LANG}" STREQUAL "C")
- message("Language is C")
-else()
- message(FATAL_ERROR "Bad language for file conly.c")
-endif()
add_library(testCModule MODULE testCModule.c)