summaryrefslogtreecommitdiffstats
path: root/Tests/CPackComponentsForAll/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-04-21 12:44:57 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2015-04-21 12:44:57 (GMT)
commit50eefbb7e3887ea66f82cbb961fdf7eb69868147 (patch)
tree2189c5c74e8a2236160b7e1f6368630158354131 /Tests/CPackComponentsForAll/CMakeLists.txt
parent3961ccb972a490ead4490b49e373af0c5bc2375a (diff)
parentcd953bf7a06fd9d96aaa5d70509535a3ba9ce665 (diff)
downloadCMake-50eefbb7e3887ea66f82cbb961fdf7eb69868147.zip
CMake-50eefbb7e3887ea66f82cbb961fdf7eb69868147.tar.gz
CMake-50eefbb7e3887ea66f82cbb961fdf7eb69868147.tar.bz2
Merge topic 'cpack-rpm-refactored-file-listing'
cd953bf7 Help: Add notes for topic 'cpack-rpm-refactored-file-listing' 76080c32 CPackRPM content listing refactor 152e9b32 CPackRPM package content list code move
Diffstat (limited to 'Tests/CPackComponentsForAll/CMakeLists.txt')
-rw-r--r--Tests/CPackComponentsForAll/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/Tests/CPackComponentsForAll/CMakeLists.txt b/Tests/CPackComponentsForAll/CMakeLists.txt
index 1cc34b0..823f6db 100644
--- a/Tests/CPackComponentsForAll/CMakeLists.txt
+++ b/Tests/CPackComponentsForAll/CMakeLists.txt
@@ -50,6 +50,13 @@ install(FILES mylib.h
COMPONENT headers)
if("${CPACK_GENERATOR}" MATCHES "RPM")
+ ############## test man pages
+ install(FILES mylib
+ DESTINATION share/man/mylib/man3/mylib.1)
+ install(FILES mylib
+ DESTINATION share/man/mylib/man3/mylib.1 RENAME mylib2)
+
+ ############## test symlinks
# Package symbolic links
install(DIRECTORY DESTINATION ${CMAKE_INSTALL_LIBDIR}/inside_relocatable_one/depth_two/depth_three COMPONENT libraries)
install(DIRECTORY DESTINATION ${CMAKE_INSTALL_LIBDIR}/inside_relocatable_two/depth_two/different_relocatable/bar COMPONENT libraries)