summaryrefslogtreecommitdiffstats
path: root/Tests/CPackComponentsForAll/CMakeLists.txt
diff options
context:
space:
mode:
authorDomen Vrankar <domen.vrankar@gmail.com>2015-01-20 23:29:46 (GMT)
committerBrad King <brad.king@kitware.com>2015-01-29 15:48:58 (GMT)
commit3ec025472735c22cb90b09bc171190005dd28bb1 (patch)
treeef09aed4a19e40b892c3228fb0f2aa3051c22423 /Tests/CPackComponentsForAll/CMakeLists.txt
parent8c4b7c567bbb47ed9555da2bd50b672304ccb858 (diff)
downloadCMake-3ec025472735c22cb90b09bc171190005dd28bb1.zip
CMake-3ec025472735c22cb90b09bc171190005dd28bb1.tar.gz
CMake-3ec025472735c22cb90b09bc171190005dd28bb1.tar.bz2
CPackRPM: Allow multiple path relocation prefixes for one package
Diffstat (limited to 'Tests/CPackComponentsForAll/CMakeLists.txt')
-rw-r--r--Tests/CPackComponentsForAll/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Tests/CPackComponentsForAll/CMakeLists.txt b/Tests/CPackComponentsForAll/CMakeLists.txt
index ff40e30..b55594e 100644
--- a/Tests/CPackComponentsForAll/CMakeLists.txt
+++ b/Tests/CPackComponentsForAll/CMakeLists.txt
@@ -110,6 +110,12 @@ set(CPACK_COMPONENT_LIBRARIES_INSTALL_TYPES Developer Full)
set(CPACK_COMPONENT_HEADERS_INSTALL_TYPES Developer Full)
set(CPACK_COMPONENT_APPLICATIONS_INSTALL_TYPES Full)
+# set CPACK_RPM_RELOCATION_PATHS here as GNUInstallDirs script
+# can not be used in CPack scripts due to CMAKE_SIZEOF_VOID_P
+# variable not being set
+set(CPACK_RPM_RELOCATION_PATHS "${CMAKE_INSTALL_INCLUDEDIR}"
+ "${CMAKE_INSTALL_LIBDIR}" "${CMAKE_INSTALL_BINDIR}")
+
# We may use the CPack specific config file in order
# to tailor CPack behavior on a CPack generator specific way
# (Behavior would be different for RPM or TGZ or DEB ...)