summaryrefslogtreecommitdiffstats
path: root/Tests/CPackComponentsForAll/CMakeLists.txt
diff options
context:
space:
mode:
authorDomen Vrankar <domen.vrankar@gmail.com>2015-04-19 16:22:18 (GMT)
committerDomen Vrankar <domen.vrankar@gmail.com>2015-04-19 16:22:18 (GMT)
commit76080c32e167b2eadf4305fb3af56ba1c7503c44 (patch)
tree2787f67fe9cff55c140a551e1efc19cf50d15633 /Tests/CPackComponentsForAll/CMakeLists.txt
parent152e9b3250d2b75d91b1058e01dfc4b46bb486cd (diff)
downloadCMake-76080c32e167b2eadf4305fb3af56ba1c7503c44.zip
CMake-76080c32e167b2eadf4305fb3af56ba1c7503c44.tar.gz
CMake-76080c32e167b2eadf4305fb3af56ba1c7503c44.tar.bz2
CPackRPM content listing refactor
Refactoring of content list that removes use of find and sed to make listing algorithm more clear and remove external dependencies. Patch also limits man pages handling to locations listed in brp-compress rpm script by default - fixes bug report #14660.
Diffstat (limited to 'Tests/CPackComponentsForAll/CMakeLists.txt')
-rw-r--r--Tests/CPackComponentsForAll/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/Tests/CPackComponentsForAll/CMakeLists.txt b/Tests/CPackComponentsForAll/CMakeLists.txt
index 1cc34b0..823f6db 100644
--- a/Tests/CPackComponentsForAll/CMakeLists.txt
+++ b/Tests/CPackComponentsForAll/CMakeLists.txt
@@ -50,6 +50,13 @@ install(FILES mylib.h
COMPONENT headers)
if("${CPACK_GENERATOR}" MATCHES "RPM")
+ ############## test man pages
+ install(FILES mylib
+ DESTINATION share/man/mylib/man3/mylib.1)
+ install(FILES mylib
+ DESTINATION share/man/mylib/man3/mylib.1 RENAME mylib2)
+
+ ############## test symlinks
# Package symbolic links
install(DIRECTORY DESTINATION ${CMAKE_INSTALL_LIBDIR}/inside_relocatable_one/depth_two/depth_three COMPONENT libraries)
install(DIRECTORY DESTINATION ${CMAKE_INSTALL_LIBDIR}/inside_relocatable_two/depth_two/different_relocatable/bar COMPONENT libraries)