summaryrefslogtreecommitdiffstats
path: root/Tests/CPackComponentsForAll/CMakeLists.txt
diff options
context:
space:
mode:
authorEric NOULARD <eric.noulard@gmail.com>2011-03-13 20:15:49 (GMT)
committerEric NOULARD <eric.noulard@gmail.com>2011-03-13 20:15:49 (GMT)
commita20102862629db49980b52f5088eae79d961237a (patch)
tree95ce06ba82c736412d4dd5d2ec37a3c9f0d5e05c /Tests/CPackComponentsForAll/CMakeLists.txt
parent7ebbcf19deacf0e894496d5bda1661142bd94702 (diff)
downloadCMake-a20102862629db49980b52f5088eae79d961237a.zip
CMake-a20102862629db49980b52f5088eae79d961237a.tar.gz
CMake-a20102862629db49980b52f5088eae79d961237a.tar.bz2
CPack try to please SUSE 64 bits and install lib in lib64 and not lib.
Diffstat (limited to 'Tests/CPackComponentsForAll/CMakeLists.txt')
-rw-r--r--Tests/CPackComponentsForAll/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/Tests/CPackComponentsForAll/CMakeLists.txt b/Tests/CPackComponentsForAll/CMakeLists.txt
index bcec509..ce12b3b 100644
--- a/Tests/CPackComponentsForAll/CMakeLists.txt
+++ b/Tests/CPackComponentsForAll/CMakeLists.txt
@@ -10,6 +10,14 @@
cmake_minimum_required(VERSION 2.8.3.20101130 FATAL_ERROR)
project(CPackComponentsForAll)
+set(LIBDEST "lib")
+include(${CMAKE_SOURCE_DIR}/SystemSpecificInformations.cmake)
+if(DISTRO_ID MATCHES "SUSE")
+ if("${CMAKE_SIZEOF_VOID_P}" EQUAL 8)
+ set(LIBDEST "lib64")
+ endif("${CMAKE_SIZEOF_VOID_P}" EQUAL 8)
+endif(DISTRO_ID MATCHES "SUSE")
+
# Create the mylib library
add_library(mylib mylib.cpp)
@@ -27,7 +35,7 @@ target_link_libraries(mylibapp2 mylib)
# be used to create the installation components.
install(TARGETS mylib
ARCHIVE
- DESTINATION lib
+ DESTINATION ${LIBDEST}
COMPONENT libraries)
install(TARGETS mylibapp
RUNTIME