summaryrefslogtreecommitdiffstats
path: root/Tests/CPackNSISGenerator/CMakeLists.txt
diff options
context:
space:
mode:
authorJohnny Jazeix <jazeix@gmail.com>2021-02-07 15:10:57 (GMT)
committerJohnny Jazeix <jazeix@gmail.com>2021-02-07 15:10:57 (GMT)
commit0aabeb0c30bae9509f46fdd2d27e8b724b853d6e (patch)
treeff5adfea94e480814a9ebf46f8529e2ca9d133f0 /Tests/CPackNSISGenerator/CMakeLists.txt
parent51f7d7e919bab508d898770f44a1f57e7a748895 (diff)
downloadCMake-0aabeb0c30bae9509f46fdd2d27e8b724b853d6e.zip
CMake-0aabeb0c30bae9509f46fdd2d27e8b724b853d6e.tar.gz
CMake-0aabeb0c30bae9509f46fdd2d27e8b724b853d6e.tar.bz2
CPack/NSIS: Add option for setting branding text
See https://nsis.sourceforge.io/Reference/BrandingText for more information. Fixes: #21479
Diffstat (limited to 'Tests/CPackNSISGenerator/CMakeLists.txt')
-rw-r--r--Tests/CPackNSISGenerator/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/CPackNSISGenerator/CMakeLists.txt b/Tests/CPackNSISGenerator/CMakeLists.txt
index 8ed4d59..64a8ef6 100644
--- a/Tests/CPackNSISGenerator/CMakeLists.txt
+++ b/Tests/CPackNSISGenerator/CMakeLists.txt
@@ -17,5 +17,7 @@ set(CPACK_NSIS_MUI_UNIICON "${PROJECT_SOURCE_DIR}\\\\uninstall.ico")
set(CPACK_GENERATOR "NSIS")
set(CPACK_NSIS_ENABLE_UNINSTALL_BEFORE_INSTALL ON)
set(CPACK_NSIS_MANIFEST_DPI_AWARE ON)
+set(CPACK_NSIS_BRANDING_TEXT "CMake branding text")
+set(CPACK_NSIS_BRANDING_TEXT_TRIM_POSITION "RIGHT")
include(CPack)