summaryrefslogtreecommitdiffstats
path: root/Tests/CPackTestAllGenerators/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2009-10-20 18:31:10 (GMT)
committerDavid Cole <david.cole@kitware.com>2009-10-20 18:31:10 (GMT)
commite1458ae4ab97a4ac668fd9153c6624e9e0e526b5 (patch)
tree13ce1429eaee8b4ebf62d986412d1165c938c5c3 /Tests/CPackTestAllGenerators/CMakeLists.txt
parent78174651b696a8e20ae55291a3b157bcab412408 (diff)
downloadCMake-e1458ae4ab97a4ac668fd9153c6624e9e0e526b5.zip
CMake-e1458ae4ab97a4ac668fd9153c6624e9e0e526b5.tar.gz
CMake-e1458ae4ab97a4ac668fd9153c6624e9e0e526b5.tar.bz2
Add test of all available CPack generators. Add this test with the goal of increasing coverage of the cpack source code, even/especially when the underlying packager tool is not installed. The test does not fail if there is a cpack problem with a certain generator. I expect some generators will fail on every machine running a CMake dashboard.
Diffstat (limited to 'Tests/CPackTestAllGenerators/CMakeLists.txt')
-rw-r--r--Tests/CPackTestAllGenerators/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tests/CPackTestAllGenerators/CMakeLists.txt b/Tests/CPackTestAllGenerators/CMakeLists.txt
new file mode 100644
index 0000000..5eeb7e9
--- /dev/null
+++ b/Tests/CPackTestAllGenerators/CMakeLists.txt
@@ -0,0 +1,5 @@
+cmake_minimum_required(VERSION 2.8)
+project(CPackTestAllGenerators)
+add_subdirectory(../CTestTest/SmallAndFast SmallAndFast)
+install(FILES RunCPack.cmake DESTINATION .)
+include(CPack)