summaryrefslogtreecommitdiffstats
path: root/Tests/CPackWiXGenerator/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2020-05-25 15:09:53 (GMT)
committerKitware Robot <kwrobot@kitware.com>2020-05-25 15:10:06 (GMT)
commit3ed8b663a9fd6e8d6f7ec0571ab1e3530f9156db (patch)
tree0a8b030dd26e121451aceca82e8ddef8439a81ae /Tests/CPackWiXGenerator/CMakeLists.txt
parenta354b7f21e858728606ddc7c275bad35914d8eaa (diff)
parentb566f0b30817270c89fc64bb11fade61bd08d0c0 (diff)
downloadCMake-3ed8b663a9fd6e8d6f7ec0571ab1e3530f9156db.zip
CMake-3ed8b663a9fd6e8d6f7ec0571ab1e3530f9156db.tar.gz
CMake-3ed8b663a9fd6e8d6f7ec0571ab1e3530f9156db.tar.bz2
Merge topic 'gitlab-ci-regular-builders'
b566f0b308 gitlab-ci: add windows builder 5b564c371e gitlab-ci: add Windows infrastructure 809f9a9916 gitlab: add powershell scripts for utilities 02c56b71a1 gitlab-ci: add a macos builder a1b1fc611b gitlab-ci: add Linux makefiles and ninja builders 3e1a1ba92d ci: add dependencies for the test suite to the Fedora image d5438f783a ci: add make to the CI image 0ed7e424ab gitlab-ci: use the cmake_build_unix anchor ... Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !4723
Diffstat (limited to 'Tests/CPackWiXGenerator/CMakeLists.txt')
-rw-r--r--Tests/CPackWiXGenerator/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CPackWiXGenerator/CMakeLists.txt b/Tests/CPackWiXGenerator/CMakeLists.txt
index 73eaf4f..940e849 100644
--- a/Tests/CPackWiXGenerator/CMakeLists.txt
+++ b/Tests/CPackWiXGenerator/CMakeLists.txt
@@ -49,6 +49,9 @@ set(CPACK_PACKAGE_INSTALL_DIRECTORY "CPack Component Example")
set(CPACK_WIX_UPGRADE_GUID "BF20CE5E-7F7C-401D-8F7C-AB45E8D170E6")
set(CPACK_WIX_UNINSTALL "1")
+# Support non-interactive sessions (like CI).
+set(CPACK_WIX_LIGHT_EXTRA_FLAGS "-sval")
+
set(CPACK_PACKAGE_EXECUTABLES
"my-libapp" "CPack WiX Test"
"my-other-app" "Second CPack WiX Test"