summaryrefslogtreecommitdiffstats
path: root/Tests/CSharpOnly/CMakeLists.txt
diff options
context:
space:
mode:
authorKinan Mahdi <kinan.mahdi@gmail.com>2020-02-18 16:06:56 (GMT)
committerBrad King <brad.king@kitware.com>2020-02-28 16:42:01 (GMT)
commitac6b18cd907392e4a6d5d76ac0f9e173a9cc7e32 (patch)
tree23315246444c32b4f30503e07518fd2cb87245d8 /Tests/CSharpOnly/CMakeLists.txt
parent8625ffd939b3c74944f6da9652777f7ca137b856 (diff)
downloadCMake-ac6b18cd907392e4a6d5d76ac0f9e173a9cc7e32.zip
CMake-ac6b18cd907392e4a6d5d76ac0f9e173a9cc7e32.tar.gz
CMake-ac6b18cd907392e4a6d5d76ac0f9e173a9cc7e32.tar.bz2
CSharp: Add support for source groups with out-of-source builds
This also fixes support for multiple sources of the same name in different directories. Add a test for both problems. Issue: #19505
Diffstat (limited to 'Tests/CSharpOnly/CMakeLists.txt')
-rw-r--r--Tests/CSharpOnly/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/Tests/CSharpOnly/CMakeLists.txt b/Tests/CSharpOnly/CMakeLists.txt
index 82049c7..42cbe2e 100644
--- a/Tests/CSharpOnly/CMakeLists.txt
+++ b/Tests/CSharpOnly/CMakeLists.txt
@@ -2,7 +2,9 @@
project (CSharpOnly CSharp)
# C# does not make any difference between STATIC and SHARED libs
-add_library(lib1 STATIC lib1.cs)
+add_library(lib1 STATIC lib1.cs nested/lib1.cs)
+#without the source group this test will fail to compile
+source_group(nested FILES nested/lib1.cs)
add_library(lib2 SHARED lib2.cs)
add_executable(CSharpOnly csharponly.cs)