summaryrefslogtreecommitdiffstats
path: root/Tests/CTestTest/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2004-05-10 22:06:11 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2004-05-10 22:06:11 (GMT)
commit0b2bdfa2898f4dd5beb0be5a7cf2964936ecda65 (patch)
tree8cd23ad53792180607e38247fcbd1aeb61eb549d /Tests/CTestTest/CMakeLists.txt
parent04016278c6e4deed1b763dce9c0aa9b8bc06afae (diff)
downloadCMake-0b2bdfa2898f4dd5beb0be5a7cf2964936ecda65.zip
CMake-0b2bdfa2898f4dd5beb0be5a7cf2964936ecda65.tar.gz
CMake-0b2bdfa2898f4dd5beb0be5a7cf2964936ecda65.tar.bz2
ENH: Add some ctest coverage
Diffstat (limited to 'Tests/CTestTest/CMakeLists.txt')
-rw-r--r--Tests/CTestTest/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Tests/CTestTest/CMakeLists.txt b/Tests/CTestTest/CMakeLists.txt
new file mode 100644
index 0000000..d2ed060
--- /dev/null
+++ b/Tests/CTestTest/CMakeLists.txt
@@ -0,0 +1,12 @@
+PROJECT(CTestTest)
+
+SET(DART_ROOT "" CACHE STRING "" FORCE)
+ENABLE_TESTING()
+INCLUDE (${CMAKE_ROOT}/Modules/Dart.cmake)
+
+GET_FILENAME_COMPONENT(CTEST_COMMAND "${CMAKE_COMMAND}" PATH)
+SET(CTEST_COMMAND "${CTEST_COMMAND}/ctest")
+
+
+CONFIGURE_FILE(${CTestTest_SOURCE_DIR}/test.cmake.in
+ ${CTestTest_BINARY_DIR}/test.cmake @ONLY)