summaryrefslogtreecommitdiffstats
path: root/Tests/CTestTest/SmallAndFast/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2009-10-15 16:35:54 (GMT)
committerDavid Cole <david.cole@kitware.com>2009-10-15 16:35:54 (GMT)
commit680fae9c978ea02b86601171512974a9ade57fbc (patch)
treebfd5fffa7a1e31205f83d51e943a40d395b8300c /Tests/CTestTest/SmallAndFast/CMakeLists.txt
parentd03c6d970fc3569ef017ebb20c09bac40ae04416 (diff)
downloadCMake-680fae9c978ea02b86601171512974a9ade57fbc.zip
CMake-680fae9c978ea02b86601171512974a9ade57fbc.tar.gz
CMake-680fae9c978ea02b86601171512974a9ade57fbc.tar.bz2
Increase ctest coverage. Introduce optionally on intentional compile errors and warnings to the SmallAndFast project. Turn them on for the FailedSubmit tests to cover analyzing LABELS-related errors and warnings.
Diffstat (limited to 'Tests/CTestTest/SmallAndFast/CMakeLists.txt')
-rw-r--r--Tests/CTestTest/SmallAndFast/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Tests/CTestTest/SmallAndFast/CMakeLists.txt b/Tests/CTestTest/SmallAndFast/CMakeLists.txt
index ee608c0..85cb30c 100644
--- a/Tests/CTestTest/SmallAndFast/CMakeLists.txt
+++ b/Tests/CTestTest/SmallAndFast/CMakeLists.txt
@@ -15,3 +15,11 @@ set_property(TEST test1 APPEND PROPERTY LABELS TestLabel 1ArgTest Everything)
add_test(test2 echoargs 1 2)
set_property(TEST test2 APPEND PROPERTY LABELS TestLabel 2ArgTest Everything)
+
+if(SAF_INTENTIONAL_COMPILE_ERROR)
+ add_executable(ice intentional_compile_error.cxx)
+endif()
+
+if(SAF_INTENTIONAL_COMPILE_WARNING)
+ add_executable(icw intentional_compile_warning.cxx)
+endif()