summaryrefslogtreecommitdiffstats
path: root/Tests/CTestTest/SmallAndFast/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2009-10-08 16:17:03 (GMT)
committerDavid Cole <david.cole@kitware.com>2009-10-08 16:17:03 (GMT)
commitc16ac1a31d6e435eef4c8752acf0cfc4cce0cdef (patch)
tree823c0f62267402640f4ba619581756b1c1da4820 /Tests/CTestTest/SmallAndFast/CMakeLists.txt
parent65b6a8f54a90b2eff3dbacc01fbd25675308b77a (diff)
downloadCMake-c16ac1a31d6e435eef4c8752acf0cfc4cce0cdef.zip
CMake-c16ac1a31d6e435eef4c8752acf0cfc4cce0cdef.tar.gz
CMake-c16ac1a31d6e435eef4c8752acf0cfc4cce0cdef.tar.bz2
Reduce duration of ctest_sleep arguments. Add SmallAndFast project. Replace kwsys with SmallAndFast to make CTestTest faster. (I will keep an eye on coverage results after this commit and make sure we still have equivalent ctest coverage.)
Diffstat (limited to 'Tests/CTestTest/SmallAndFast/CMakeLists.txt')
-rw-r--r--Tests/CTestTest/SmallAndFast/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Tests/CTestTest/SmallAndFast/CMakeLists.txt b/Tests/CTestTest/SmallAndFast/CMakeLists.txt
new file mode 100644
index 0000000..51aa887
--- /dev/null
+++ b/Tests/CTestTest/SmallAndFast/CMakeLists.txt
@@ -0,0 +1,10 @@
+cmake_minimum_required(VERSION 2.8)
+project(SmallAndFast)
+
+include(CTest)
+
+add_executable(echoargs echoargs.c)
+
+add_test(test0 echoargs)
+add_test(test1 echoargs 1)
+add_test(test2 echoargs 1 2)