summaryrefslogtreecommitdiffstats
path: root/Tests/CTestTestCostSerial/CMakeLists.txt
diff options
context:
space:
mode:
authorKitware Robot <kwrobot@kitware.com>2012-08-13 17:47:32 (GMT)
committerBrad King <brad.king@kitware.com>2012-08-13 18:19:16 (GMT)
commit77543bde41b0e52c3959016698b529835945d62d (patch)
treeff63e5fbec326c4a5d821e7496c6d2cb52f75b92 /Tests/CTestTestCostSerial/CMakeLists.txt
parent7bbaa4283de26864b2e55e819db0884771585467 (diff)
downloadCMake-77543bde41b0e52c3959016698b529835945d62d.zip
CMake-77543bde41b0e52c3959016698b529835945d62d.tar.gz
CMake-77543bde41b0e52c3959016698b529835945d62d.tar.bz2
Convert CMake-language commands to lower case
Ancient CMake versions required upper-case commands. Later command names became case-insensitive. Now the preferred style is lower-case. Run the following shell code: cmake --help-command-list | grep -v "cmake version" | while read c; do echo 's/\b'"$(echo $c | tr '[:lower:]' '[:upper:]')"'\(\s*\)(/'"$c"'\1(/g' done >convert.sed && git ls-files -z -- bootstrap '*.cmake' '*.cmake.in' '*CMakeLists.txt' | egrep -z -v '^(Utilities/cm|Source/kwsys/)' | xargs -0 sed -i -f convert.sed && rm convert.sed
Diffstat (limited to 'Tests/CTestTestCostSerial/CMakeLists.txt')
-rw-r--r--Tests/CTestTestCostSerial/CMakeLists.txt20
1 files changed, 10 insertions, 10 deletions
diff --git a/Tests/CTestTestCostSerial/CMakeLists.txt b/Tests/CTestTestCostSerial/CMakeLists.txt
index a9a5c25..29d2983 100644
--- a/Tests/CTestTestCostSerial/CMakeLists.txt
+++ b/Tests/CTestTestCostSerial/CMakeLists.txt
@@ -1,13 +1,13 @@
-CMAKE_MINIMUM_REQUIRED (VERSION 2.6)
-PROJECT (CTestTestCostSerial)
-INCLUDE (CTest)
+cmake_minimum_required (VERSION 2.6)
+project (CTestTestCostSerial)
+include (CTest)
-ADD_EXECUTABLE (Sleep sleep.c)
+add_executable (Sleep sleep.c)
-FOREACH (index RANGE 1 3)
- ADD_TEST (TestSleep${index} Sleep)
-ENDFOREACH (index RANGE 1 3)
+foreach (index RANGE 1 3)
+ add_test (TestSleep${index} Sleep)
+endforeach (index RANGE 1 3)
-SET_TESTS_PROPERTIES(TestSleep1 PROPERTIES COST -500)
-SET_TESTS_PROPERTIES(TestSleep2 PROPERTIES COST 12)
-SET_TESTS_PROPERTIES(TestSleep3 PROPERTIES COST 0)
+set_tests_properties(TestSleep1 PROPERTIES COST -500)
+set_tests_properties(TestSleep2 PROPERTIES COST 12)
+set_tests_properties(TestSleep3 PROPERTIES COST 0)