summaryrefslogtreecommitdiffstats
path: root/Tests/CTestTestCycle/CMakeLists.txt
diff options
context:
space:
mode:
authorZach Mullen <zach.mullen@kitware.com>2010-06-30 14:39:17 (GMT)
committerZach Mullen <zach.mullen@kitware.com>2010-06-30 14:39:17 (GMT)
commit3e52000a07cb71172bc0ff7223dbca6f793786b6 (patch)
tree9b3d206df0385e8d6f6af76118a97b9ab581a877 /Tests/CTestTestCycle/CMakeLists.txt
parentb65cd9b70b52dc36d51165bd00d551ce01b0465b (diff)
downloadCMake-3e52000a07cb71172bc0ff7223dbca6f793786b6.zip
CMake-3e52000a07cb71172bc0ff7223dbca6f793786b6.tar.gz
CMake-3e52000a07cb71172bc0ff7223dbca6f793786b6.tar.bz2
Fix cycle detection for test dependencies
Diffstat (limited to 'Tests/CTestTestCycle/CMakeLists.txt')
-rw-r--r--Tests/CTestTestCycle/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Tests/CTestTestCycle/CMakeLists.txt b/Tests/CTestTestCycle/CMakeLists.txt
new file mode 100644
index 0000000..6ba6b8c
--- /dev/null
+++ b/Tests/CTestTestCycle/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required (VERSION 2.6)
+project(CTestTestCycle)
+include(CTest)
+
+add_executable (simple simple.cxx)
+add_test (one simple)
+add_test (two simple)
+add_test (three simple)
+
+# Add cyclical test dependency
+set_tests_properties(one PROPERTIES DEPENDS "two")
+set_tests_properties(two PROPERTIES DEPENDS "three")
+set_tests_properties(three PROPERTIES DEPENDS "one")