summaryrefslogtreecommitdiffstats
path: root/Tests/CTestTestMemcheck/DummyValgrindPrePost/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2012-10-17 20:43:02 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2012-10-17 20:43:02 (GMT)
commita2871e93ee7782838ae59ff91e42a2ce967e8ce0 (patch)
tree099554de457573fae7a60c47224d1e6d77cc4d66 /Tests/CTestTestMemcheck/DummyValgrindPrePost/CMakeLists.txt
parenta56b8e436f4f7e90f62c83fc6e9a1374e73c0624 (diff)
parent995a35fe12e9582c4488a7bc2deb66b0e4d25315 (diff)
downloadCMake-a2871e93ee7782838ae59ff91e42a2ce967e8ce0.zip
CMake-a2871e93ee7782838ae59ff91e42a2ce967e8ce0.tar.gz
CMake-a2871e93ee7782838ae59ff91e42a2ce967e8ce0.tar.bz2
Merge topic 'test-ctest-memcheck'
995a35f CTest: add a check with a quoted memory checker de8bffc CTest: add a test for CTEST_CUSTOM_MEMCHECK_IGNORE d26c9b6 CTest: improve memory checker type detection fcae1da CTest: add tests that simulate memcheck runs 6187876 CTest: fix pre and post test commands with spaces 95bc8aa CTest: fix usage of memory checker with spaces in path
Diffstat (limited to 'Tests/CTestTestMemcheck/DummyValgrindPrePost/CMakeLists.txt')
-rw-r--r--Tests/CTestTestMemcheck/DummyValgrindPrePost/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tests/CTestTestMemcheck/DummyValgrindPrePost/CMakeLists.txt b/Tests/CTestTestMemcheck/DummyValgrindPrePost/CMakeLists.txt
new file mode 100644
index 0000000..bc15632
--- /dev/null
+++ b/Tests/CTestTestMemcheck/DummyValgrindPrePost/CMakeLists.txt
@@ -0,0 +1,5 @@
+cmake_minimum_required(VERSION 2.8.9)
+project(CTestTestMemcheckDummyValgrindPrePost)
+include(CTest)
+
+add_test (RunCMake "${CMAKE_COMMAND}")