summaryrefslogtreecommitdiffstats
path: root/Tests/CTestTestMemcheck/NoLogDummyChecker/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-12-16 18:59:22 (GMT)
committerBrad King <brad.king@kitware.com>2014-12-18 15:12:16 (GMT)
commit7ca6bdf0355157da9f85f6bbf039a632ffdf66b7 (patch)
tree0665524d4973903b38fa6779d85c328b6f2305b4 /Tests/CTestTestMemcheck/NoLogDummyChecker/CMakeLists.txt
parent1651dc96683282c0af8ef47973db9afa950d6bde (diff)
downloadCMake-7ca6bdf0355157da9f85f6bbf039a632ffdf66b7.zip
CMake-7ca6bdf0355157da9f85f6bbf039a632ffdf66b7.tar.gz
CMake-7ca6bdf0355157da9f85f6bbf039a632ffdf66b7.tar.bz2
Tests: Move CTestTestMemcheck tools into Tests/CMakeLib
The dummy memcheck tools we build for the RunCMake.CTestMemcheck tests require CMakeLib, so put them in a Tests/CMakeLib/PseudoMemcheck directory.
Diffstat (limited to 'Tests/CTestTestMemcheck/NoLogDummyChecker/CMakeLists.txt')
-rw-r--r--Tests/CTestTestMemcheck/NoLogDummyChecker/CMakeLists.txt22
1 files changed, 0 insertions, 22 deletions
diff --git a/Tests/CTestTestMemcheck/NoLogDummyChecker/CMakeLists.txt b/Tests/CTestTestMemcheck/NoLogDummyChecker/CMakeLists.txt
deleted file mode 100644
index 3a45bfe..0000000
--- a/Tests/CTestTestMemcheck/NoLogDummyChecker/CMakeLists.txt
+++ /dev/null
@@ -1,22 +0,0 @@
-# A dummy checker implementation that does not write the requested output file
-# so it triggers an error for every checker.
-
-file(WRITE "${CMAKE_CURRENT_BINARY_DIR}/ret0.c.in" "int main(){return 0;}\n")
-
-configure_file(
- "${CMAKE_CURRENT_BINARY_DIR}/ret0.c.in"
- "${CMAKE_CURRENT_BINARY_DIR}/ret0.c"
- )
-
-foreach(_pseudo IN ITEMS valgrind purify BC)
- add_executable(pseudonl_${_pseudo} "${CMAKE_CURRENT_BINARY_DIR}/ret0.c")
- set_target_properties(pseudonl_${_pseudo} PROPERTIES OUTPUT_NAME ${_pseudo})
-
- # Xcode 2.x forgets to create the output directory before linking
- # the individual architectures.
- if(CMAKE_OSX_ARCHITECTURES AND XCODE AND NOT "${XCODE_VERSION}" MATCHES "^[^12]")
- add_custom_command(TARGET pseudonl_${_pseudo}
- PRE_BUILD COMMAND ${CMAKE_COMMAND} -E make_directory "${CMAKE_CFG_INTDIR}"
- )
- endif()
-endforeach()