summaryrefslogtreecommitdiffstats
path: root/Tests/CTestTestResourceLock/CMakeLists.txt
diff options
context:
space:
mode:
authorZach Mullen <zach.mullen@kitware.com>2010-03-03 15:32:03 (GMT)
committerZach Mullen <zach.mullen@kitware.com>2010-03-03 15:33:09 (GMT)
commit2fd9b8072bb15e16446e15c1165566d4a238e4cc (patch)
treec302a7efb0e2a4df2154f1c591e0ae8a4698286e /Tests/CTestTestResourceLock/CMakeLists.txt
parentadca29a5beca6f25d1224176584ea7c4ef0bf360 (diff)
downloadCMake-2fd9b8072bb15e16446e15c1165566d4a238e4cc.zip
CMake-2fd9b8072bb15e16446e15c1165566d4a238e4cc.tar.gz
CMake-2fd9b8072bb15e16446e15c1165566d4a238e4cc.tar.bz2
Add unit test for RESOURCE_LOCK test property
Diffstat (limited to 'Tests/CTestTestResourceLock/CMakeLists.txt')
-rw-r--r--Tests/CTestTestResourceLock/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Tests/CTestTestResourceLock/CMakeLists.txt b/Tests/CTestTestResourceLock/CMakeLists.txt
new file mode 100644
index 0000000..1041ef1
--- /dev/null
+++ b/Tests/CTestTestResourceLock/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required (VERSION 2.6)
+PROJECT(CTestTestResourceLock)
+INCLUDE(CTest)
+
+ADD_EXECUTABLE (LockFile lockFile.c)
+
+ADD_TEST (TestLockedFile1.1 LockFile locked1.txt)
+ADD_TEST (TestLockedFile1.2 LockFile locked1.txt)
+SET_TESTS_PROPERTIES(TestLockedFile1.1 TestLockedFile1.2 PROPERTIES RESOURCE_LOCK "locked1.txt")
+
+ADD_TEST (TestLockedFile2.1 LockFile locked2.txt)
+ADD_TEST (TestLockedFile2.2 LockFile locked2.txt)
+SET_TESTS_PROPERTIES(TestLockedFile2.1 TestLockedFile2.2 PROPERTIES RESOURCE_LOCK "locked2.txt")