summaryrefslogtreecommitdiffstats
path: root/Tests/CTestTestSubdir/CMakeLists.txt
diff options
context:
space:
mode:
authorZach Mullen <zach.mullen@kitware.com>2009-11-10 15:40:24 (GMT)
committerZach Mullen <zach.mullen@kitware.com>2009-11-10 15:40:24 (GMT)
commitc9c0ee4056aa651a63ee6c34abb06e60e987dbe3 (patch)
tree869a02a81b1ff9cc2790bd73290030d743fac854 /Tests/CTestTestSubdir/CMakeLists.txt
parent21a59bdc4d4c54af5cd175561f9249d5932434d2 (diff)
downloadCMake-c9c0ee4056aa651a63ee6c34abb06e60e987dbe3.zip
CMake-c9c0ee4056aa651a63ee6c34abb06e60e987dbe3.tar.gz
CMake-c9c0ee4056aa651a63ee6c34abb06e60e987dbe3.tar.bz2
Change logic of ctest subdirs command to allow for absolute paths. Also added test coverage for passing absolute paths to subdirs.
Diffstat (limited to 'Tests/CTestTestSubdir/CMakeLists.txt')
-rw-r--r--Tests/CTestTestSubdir/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/CTestTestSubdir/CMakeLists.txt b/Tests/CTestTestSubdir/CMakeLists.txt
index f5a1fe2..5daa543 100644
--- a/Tests/CTestTestSubdir/CMakeLists.txt
+++ b/Tests/CTestTestSubdir/CMakeLists.txt
@@ -9,3 +9,5 @@ GET_FILENAME_COMPONENT(CTEST_COMMAND "${CMAKE_COMMAND}" PATH)
SET(CTEST_COMMAND "${CTEST_COMMAND}/ctest")
ADD_SUBDIRECTORY(subdir)
+SUBDIRS(subdir2)
+SUBDIRS("${CTestTestSubdir_SOURCE_DIR}/subdir3")