summaryrefslogtreecommitdiffstats
path: root/Tests/CTestTestTimeout/CMakeLists.txt
diff options
context:
space:
mode:
authorZach Mullen <zach.mullen@kitware.com>2009-09-29 19:18:46 (GMT)
committerZach Mullen <zach.mullen@kitware.com>2009-09-29 19:18:46 (GMT)
commitf321dbb17b67f7345594562a7a458fb98637eea0 (patch)
treed2e770bf1b905bb1a6d5ec38a74d4fc9be1be3b8 /Tests/CTestTestTimeout/CMakeLists.txt
parent70614b9e6a3cf4ae9b85598709736786b111ef3b (diff)
downloadCMake-f321dbb17b67f7345594562a7a458fb98637eea0.zip
CMake-f321dbb17b67f7345594562a7a458fb98637eea0.tar.gz
CMake-f321dbb17b67f7345594562a7a458fb98637eea0.tar.bz2
ENH: Added ctest test coverage for a test timeout
Diffstat (limited to 'Tests/CTestTestTimeout/CMakeLists.txt')
-rw-r--r--Tests/CTestTestTimeout/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/Tests/CTestTestTimeout/CMakeLists.txt b/Tests/CTestTestTimeout/CMakeLists.txt
new file mode 100644
index 0000000..15942c8
--- /dev/null
+++ b/Tests/CTestTestTimeout/CMakeLists.txt
@@ -0,0 +1,18 @@
+cmake_minimum_required (VERSION 2.6)
+PROJECT(CTestTestTimeout)
+
+SET(DART_ROOT "" CACHE STRING "" FORCE)
+ENABLE_TESTING()
+INCLUDE (${CMAKE_ROOT}/Modules/Dart.cmake)
+
+GET_FILENAME_COMPONENT(CTEST_COMMAND "${CMAKE_COMMAND}" PATH)
+SET(CTEST_COMMAND "${CTEST_COMMAND}/ctest")
+
+ADD_EXECUTABLE (Timeout timeout.c)
+
+ENABLE_TESTING ()
+
+ADD_TEST (TestTimeout Timeout)
+SET_TESTS_PROPERTIES(TestTimeout PROPERTIES TIMEOUT 1)
+
+INCLUDE (CTest)