summaryrefslogtreecommitdiffstats
path: root/Tests/CTestTestZeroTimeout/CMakeLists.txt
diff options
context:
space:
mode:
authorZach Mullen <zach.mullen@kitware.com>2011-01-03 19:41:25 (GMT)
committerZach Mullen <zach.mullen@kitware.com>2011-01-03 19:41:25 (GMT)
commit51bb49357495ea2742858ffe9d76ab3f44efc06e (patch)
treef72a5b8ce58fc95f46d2b477196ded88e642cda8 /Tests/CTestTestZeroTimeout/CMakeLists.txt
parentedff9207ed82d241077d66b20087657f74e8b5b9 (diff)
downloadCMake-51bb49357495ea2742858ffe9d76ab3f44efc06e.zip
CMake-51bb49357495ea2742858ffe9d76ab3f44efc06e.tar.gz
CMake-51bb49357495ea2742858ffe9d76ab3f44efc06e.tar.bz2
Test TIMEOUT property explicitly set to zero should be honored
Diffstat (limited to 'Tests/CTestTestZeroTimeout/CMakeLists.txt')
-rw-r--r--Tests/CTestTestZeroTimeout/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Tests/CTestTestZeroTimeout/CMakeLists.txt b/Tests/CTestTestZeroTimeout/CMakeLists.txt
new file mode 100644
index 0000000..8a5246d
--- /dev/null
+++ b/Tests/CTestTestZeroTimeout/CMakeLists.txt
@@ -0,0 +1,8 @@
+CMAKE_MINIMUM_REQUIRED (VERSION 2.6)
+PROJECT (CTestTestZeroTimeout)
+INCLUDE (CTest)
+
+ADD_EXECUTABLE (Sleep sleep.c)
+
+ADD_TEST (TestExplicitZeroTimeout Sleep)
+SET_TESTS_PROPERTIES(TestExplicitZeroTimeout PROPERTIES TIMEOUT 0)