summaryrefslogtreecommitdiffstats
path: root/Tests/CheckSourceTree/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2022-10-08 11:07:59 (GMT)
committerBrad King <brad.king@kitware.com>2022-10-08 11:07:59 (GMT)
commit1912d50a7093889483f3085dc6c75b8fa07fd1a5 (patch)
treec9eccfd71eb9542d4e9d261b3c233a87f88aaa1c /Tests/CheckSourceTree/CMakeLists.txt
parent269652a81468637c03bbdc4ef56e0090ccae78bb (diff)
downloadCMake-1912d50a7093889483f3085dc6c75b8fa07fd1a5.zip
CMake-1912d50a7093889483f3085dc6c75b8fa07fd1a5.tar.gz
CMake-1912d50a7093889483f3085dc6c75b8fa07fd1a5.tar.bz2
Tests: Run CheckSourceTree test using just-built CMake
Update the change from commit 8d453ee751 (Tests: Improve CheckSourceTree test, 2022-10-05) to drive the test script using the tested CMake instead of the host CMake, following the convention of other tests.
Diffstat (limited to 'Tests/CheckSourceTree/CMakeLists.txt')
-rw-r--r--Tests/CheckSourceTree/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/Tests/CheckSourceTree/CMakeLists.txt b/Tests/CheckSourceTree/CMakeLists.txt
index d5019d2..3abc6a9 100644
--- a/Tests/CheckSourceTree/CMakeLists.txt
+++ b/Tests/CheckSourceTree/CMakeLists.txt
@@ -1,6 +1,6 @@
add_test(NAME CMake.CheckSourceTree
- COMMAND ${CMAKE_COMMAND} -D GIT_EXECUTABLE=${GIT_EXECUTABLE}
- -D CMake_SOURCE_DIR=${CMake_SOURCE_DIR}
- -P ${CMAKE_CURRENT_LIST_DIR}/check.cmake
+ COMMAND ${CMAKE_CMAKE_COMMAND} -D GIT_EXECUTABLE=${GIT_EXECUTABLE}
+ -D CMake_SOURCE_DIR=${CMake_SOURCE_DIR}
+ -P ${CMAKE_CURRENT_LIST_DIR}/check.cmake
)
set_property(TEST CMake.CheckSourceTree PROPERTY RUN_SERIAL 1)