summaryrefslogtreecommitdiffstats
path: root/Tests/CompileCommandOutput/CMakeLists.txt
diff options
context:
space:
mode:
authorKitware Robot <kwrobot@kitware.com>2012-08-13 17:47:32 (GMT)
committerBrad King <brad.king@kitware.com>2012-08-13 18:19:16 (GMT)
commit77543bde41b0e52c3959016698b529835945d62d (patch)
treeff63e5fbec326c4a5d821e7496c6d2cb52f75b92 /Tests/CompileCommandOutput/CMakeLists.txt
parent7bbaa4283de26864b2e55e819db0884771585467 (diff)
downloadCMake-77543bde41b0e52c3959016698b529835945d62d.zip
CMake-77543bde41b0e52c3959016698b529835945d62d.tar.gz
CMake-77543bde41b0e52c3959016698b529835945d62d.tar.bz2
Convert CMake-language commands to lower case
Ancient CMake versions required upper-case commands. Later command names became case-insensitive. Now the preferred style is lower-case. Run the following shell code: cmake --help-command-list | grep -v "cmake version" | while read c; do echo 's/\b'"$(echo $c | tr '[:lower:]' '[:upper:]')"'\(\s*\)(/'"$c"'\1(/g' done >convert.sed && git ls-files -z -- bootstrap '*.cmake' '*.cmake.in' '*CMakeLists.txt' | egrep -z -v '^(Utilities/cm|Source/kwsys/)' | xargs -0 sed -i -f convert.sed && rm convert.sed
Diffstat (limited to 'Tests/CompileCommandOutput/CMakeLists.txt')
-rw-r--r--Tests/CompileCommandOutput/CMakeLists.txt22
1 files changed, 11 insertions, 11 deletions
diff --git a/Tests/CompileCommandOutput/CMakeLists.txt b/Tests/CompileCommandOutput/CMakeLists.txt
index bd8e305..6f9468d 100644
--- a/Tests/CompileCommandOutput/CMakeLists.txt
+++ b/Tests/CompileCommandOutput/CMakeLists.txt
@@ -2,15 +2,15 @@
cmake_minimum_required (VERSION 2.6)
project (CompileCommandOutput CXX)
-SET(CMAKE_EXPORT_COMPILE_COMMANDS ON)
+set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
set(CMAKE_DEBUG_POSTFIX "_test_debug_postfix")
-IF(MAKE_SUPPORTS_SPACES)
- SET(test1_srcs "file with spaces.cxx")
-ELSE()
- SET(test1_srcs "file_with_underscores.cxx")
-ENDIF()
-ADD_LIBRARY(test1 STATIC ${test1_srcs})
-ADD_LIBRARY(test2 SHARED "../CompileCommandOutput/relative.cxx")
-INCLUDE_DIRECTORIES(${CompileCommandOutput_SOURCE_DIR}/../../Source)
-ADD_EXECUTABLE(CompileCommandOutput compile_command_output.cxx)
-TARGET_LINK_LIBRARIES(CompileCommandOutput test1 test2)
+if(MAKE_SUPPORTS_SPACES)
+ set(test1_srcs "file with spaces.cxx")
+else()
+ set(test1_srcs "file_with_underscores.cxx")
+endif()
+add_library(test1 STATIC ${test1_srcs})
+add_library(test2 SHARED "../CompileCommandOutput/relative.cxx")
+include_directories(${CompileCommandOutput_SOURCE_DIR}/../../Source)
+add_executable(CompileCommandOutput compile_command_output.cxx)
+target_link_libraries(CompileCommandOutput test1 test2)